Talk:Romit2 VPU

From MyLabWiki
Jump to: navigation, search

Contents

Logbook

2011.08.11

Resuming work on the Gumstix Overo video processor, continuing with the original idea as described long time ago.

2011.09.06

Successful smoke test of new Tobi and Overo Water board. I now have photos on Flickr.

2011.09.09

Got the Caspa VL camera working but was very disappointed with the result. Unacceptable image quality when compared to a Logitech webcam.

2011.09.15

After many days of trial & error, I have successfully built an image with DSP support and TI Gstreamer codecs!!!

Made this blog post.

2011.09.21

It took a few more days, but I can now encode video using the DSP, see this blog.

Ordered a 3.2 megapixel and a 5 megapixe camera from e-con Systems in India.

2011.09.30

Received cameras from e-con Systems.

2011.10.09

First successful test image taken with the eCAM32 3.2 megapixel camera using the SD card that came with the camera. I can also stream video, VGA at 15 fps, 2.8 Mbps, CPU load on ARM 50%.

2011.10.11

Successfully built my own image with e-con patches and binary driver for eCAM32. Video streaming is working!

2011.10.24

The eCAM32 camera stopped working with Gstreamer and any pipeline involving v4l2src gives error:

 root@overo:~# gst-launch -v -e v4l2src ! video/x-raw-yuv,format=,width=640,height=480,framerate=20/1 ! Fakesink 
 Setting pipeline to PAUSED ... 
 ERROR: Pipeline doesn't want to pause. 
 ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Could not negotiate format
 Additional debug info: 
 gstbasesrc.c(2778): gst_base_src_start (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: 
 Check your filtered caps, if any 
 Setting pipeline to NULL ... 
 Freeing pipeline ... 
 root@overo:~#

The only thing I did since the last time it worked was to stack the Overo Water and camera board on the Tobi using metal screws.

Tried replacing the camera and the ribbon cable but no luck. Maybe the Overo or the Tobi got damaged?

The capture.elf application can still capture single frames.

2011.12.05

Re-assembled the Gumstix VPU using the old parts (including used cable). Capture.elf worked right away, but gstreamer still gives the v4l2src error. Then I exported the GST_DEBUG=v4l2src:4 ran the pipeline again and noticed that it continuously printed DEBUG and INFO messages. Killed it, set the debug level to 2 and executed the pipeline again – It was streaming!!!

While it streaming I secured the Overo and camera using 2 screws so that was not the problem

Note that when capture.elf exits, gstreamer stops streaming. I could, however, restart it every time.

2011.12.06

Retried the startup procedure I discovered yesterday, namely to start the GST pipeline with GST_DEBUG=v4l2src:2 – it still woks! It didn't work before enabling the debug. There must be some weird timing issue and the reason why it works must be that the pipeline is slower to start with debug enabled.

I have let the Gumstix stream for 6 hours using default encoder parameters:

  • CPU load steady at 22-24 %
  • Memory consumption steady at 66 MB

2011.12.12

Posted two videos showing the Gumstix OVero Water + eCAM32 streaming video to host PC over network, see this blog.